做了一个板子,STM32的4个IO口直接与74HC14的4个输入口相连,74HC14的电源是5V,中间加了4个1K的上拉电阻,上拉电阻的电源是3.3V,经过整形,74HC14有三路输出正确,一路却只是高电平,74HC14与STM32芯片没有问题,求教:出现这种状况的原因是什么? STM32输出的是4路PWM信号,幅值周期一样,只是每路的延迟不同。

系统消息 若觉得内容不错,请点击左上角的"赞"图标,以优化网站的内容呈现。 另外,请及时验证注册邮箱,否则收不到21QA发出的红包。 官方Q群:250203055

asked 19 Aug '14, 11:18

www%E7%82%B921qa%E7%82%B9net's gravatar image

www点21qa点net
717813


HC为COMS,输出是TTL电平。估计DataSheet有讲

系统消息 若觉得内容不错,请点击左上角的"赞"图标,以优化网站的内容呈现。 另外,请及时验证注册邮箱,否则收不到21QA发出的红包。 官方Q群:250203055
permanent link

answered 22 Aug '14, 21:42

Jalon's gravatar image

Jalon
11

STM32输出电流有多大?可以直接驱动74HC14么?
1 专业一点叫法是拉电流,不叫输出电流
2 拉电流由你的配置io模式决定,如果是pp模式,可达100ma,如果是开漏,1ma都没有(直接驱动)。

系统消息 若觉得内容不错,请点击左上角的"赞"图标,以优化网站的内容呈现。 另外,请及时验证注册邮箱,否则收不到21QA发出的红包。 官方Q群:250203055
permanent link

answered 20 Aug '14, 09:24

major's gravatar image

major
351283237

编辑于 20 Aug '14, 09:25

  • 两者之间是逻辑接口,上拉似乎没有必要。
  • 逻辑信号的驱动,对于STM32的IO口驱动能力足够了。
  • IO口要配置成为推挽输出,可能那个有问题的IO口正被其它的功能占用。
  • 可以用示波器看看有问题那个口的波形是否正确。
系统消息 若觉得内容不错,请点击左上角的"赞"图标,以优化网站的内容呈现。 另外,请及时验证注册邮箱,否则收不到21QA发出的红包。 官方Q群:250203055
permanent link

answered 19 Aug '14, 11:28

%E5%8E%9F%E9%87%8E%E4%B9%8B%E7%8B%BC's gravatar image

原野之狼
1.9k9399116

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link: [text](http://url.com/ "title")
  • image: ![alt](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×1
×1

question asked: 19 Aug '14, 11:18

question was seen: 3,224 times

last updated: 22 Aug '14, 21:42

Related questions

powered by O*S*Q*A

粤ICP备14040061号-1